Silverlight 5, ria services con entidad framework 6.0 alpha 3

entity-framework-6 silverlight-5.0 wcf-ria-services

Pregunta

Estoy tratando de crear una aplicación Silverlight 5.0 utilizando ria services, con entityframework 6.0 alpha 3. Este es un proyecto nuevo que nunca usó ninguna otra versión de entityframework. Todo parece compilar bien, excepto el proyecto de datos de Silverlight que se conecta al proyecto web para generar proxies. Obtuve el siguiente error:

Error 2 Método no encontrado: 'System.Data.Objects.ObjectContext System.Data.Entity.Infrastructure.IObjectContextAdapter.get_ObjectContext ()'

¿Hay alguna incompatibilidad o simplemente estoy haciendo algo mal?

Respuesta aceptada

RIA Services ahora es OpenSource con el nombre "Open RIA Services" (ver en CodePlex ).

Colin Blair, el líder del proyecto, acaba de anunciar la primera versión con soporte EF6: http://www.openriaservices.net/blog/post/The-Open-RIA-Services-Blog/1016/4-3-Alpha-NuGet -Paquetes-liberados /

Puede instalar el paquete Nuget: RIA Services para Entity Framework 6+ .

Si desea instalar los servicios RIA del paquete Nuget para Entity Framework 6+ , asegúrese de seleccionar el elemento "incluir versión preliminar" en el cuadro combinado superior.


Respuesta popular

La última versión compatible de WCF RIA Services es Entity Framework 5 . Así que no espero que esto funcione con EF 6.0.




Licencia bajo: CC-BY-SA with attribution
No afiliado con Stack Overflow
¿Es esto KB legal? Sí, aprende por qué
Licencia bajo: CC-BY-SA with attribution
No afiliado con Stack Overflow
¿Es esto KB legal? Sí, aprende por qué