BreezeJS y Entity Framework 6.0.1

breeze entity-framework entity-framework-6

Pregunta

Estoy intentando crear un controlador de API web de Breeze y me pregunto si es posible con la plantilla de proyecto MVC / API web predeterminada que viene con Visual Studio 2013. Al actualizar todo a través del administrador de paquetes Nuget, se instala Entity Framework 6.0.1. Intentar instalar Breeze después de eso da como resultado un error al intentar instalar EF 5 como una dependencia, lo que no es posible dado que otras partes de la plantilla dependen de EF6. ¿Tenemos que esperar una nueva versión de Breeze que funcione con EF6?

Edit: quiero hacer esto de la "manera fácil" usando [BreezeController] y Odata.

Respuesta aceptada

Actualizado 10/29/13

A partir de ahora, Breeze 1.4.5 tiene soporte para ASP.NET WebApi 2 de Microsoft y Entity Framework 6. Consulte http://www.breezejs.com/documentation/download .

Entrada antigua:

Todavía no apoyamos EF6 pero está llegando ... pronto ...


Respuesta popular

Solo quería agregar que, incluso sin EF6.1, las actualizaciones de MVC 5 lanzadas hoy con VS2013 también se rompen. Es difícil separar las piezas para determinar qué nueva pieza es responsable. Podría ser MVC o la nueva odata. En cualquier caso, anticipamos ansiosamente la nueva versión.




Licencia bajo: CC-BY-SA with attribution
No afiliado con Stack Overflow
¿Es esto KB legal? Sí, aprende por qué
Licencia bajo: CC-BY-SA with attribution
No afiliado con Stack Overflow
¿Es esto KB legal? Sí, aprende por qué