IdentityStoreManager est introuvable après la mise à niveau de Microsoft.AspNet.Identity vers rc1

asp.net-identity asp.net-mvc-5 entity-framework-6 visual-studio-2013

Question

Après la mise à niveau de Microsoft.AspNet.Identity.Core vers 1.0.0-rc1, plusieurs erreurs apparaissent dans les classes AccountController.cs et AppModel.cs générées par les modèles MVC5 par défaut dans Visual Studio 2013.

Existe-t-il des notes de version expliquant comment résoudre les changements importants?

Réponse acceptée

Mettez à jour les packages de nuget suivants:

  • Identité Microsoft ASP.NET EntityFramework version = "1.0.0-rc1"
  • Microsoft.Owin.Security version = "2.0.0-rc1"
  • Microsoft.Owin.Security.OAuth version = "2.0.0-rc1"

Obtenez ces:

  • Microsoft.AspNet.Identity.Owin version = "1.0.0-rc1"
  • Microsoft.Owin.Host.SystemWeb version = "2.0.0-rc1"

Ensuite, vous aurez toujours beaucoup d'erreurs dans votre fichier AccountController.cs. Mais maintenant, vous avez les classes de votre projet pour les corriger, ou vous pouvez obtenir mon fichier AccountController.cs qui est corrigé, il compile et l'application s'exécute, mais il y a un endroit (commenté avec todo :) que je ne suis pas sûr à propos de encore.

Vous pouvez télécharger mon fichier AccountController.cs à partir de mon exemple de projet sur github ici: https://github.com/onybo/Asp.Net-Identity-RC1-sample-app




Sous licence: CC-BY-SA with attribution
Non affilié à Stack Overflow
Est-ce KB légal? Oui, apprenez pourquoi
Sous licence: CC-BY-SA with attribution
Non affilié à Stack Overflow
Est-ce KB légal? Oui, apprenez pourquoi