Microsoft.AspNet.Identityをrc1にアップグレードした後にIdentityStoreManagerが見つかりませんでした

asp.net-identity asp.net-mvc-5 entity-framework-6 visual-studio-2013

質問

Microsoft.AspNet.Identity.Coreを1.0.0-rc1にアップグレードすると、Visual Studio 2013のデフォルトのMVC5テンプレートによって生成されたAccountController.csおよびAppModel.csクラスにいくつかのエラーが表示されます。

その変更を解決する方法を説明するリリースノートがありますか?

受け入れられた回答

以下のナゲットパッケージを更新してください:

  • Microsoft ASP.NET Identity EntityFrameworkバージョン= "1.0.0-rc1"
  • Microsoft.Owin.Security version = "2.0.0-rc1"
  • Microsoft.Owin.Security.OAuth version = "2.0.0-rc1"

これらを入手してください:

  • Microsoft.AspNet.Identity.Owin version = "1.0.0-rc1"
  • Microsoft.Owin.Host.SystemWeb version = "2.0.0-rc1"

その後も、AccountController.csファイルには多くのエラーがあります。しかし、今、あなたのプロジェクトにそれらを修正するためのクラスがありますか、または固定されている私のAccountController.csファイルを取得することができます、それはコンパイルされ、アプリケーションが実行されますが、(私は確信していますまだ

https://github.com/onybo/Asp.Net-Identity-RC1-sample-appここでgithubのサンプルプロジェクトからAccountController.csファイルをダウンロードできます



Related

ライセンスを受けた: CC-BY-SA with attribution
所属していない Stack Overflow
このKBは合法ですか? はい、理由を学ぶ
ライセンスを受けた: CC-BY-SA with attribution
所属していない Stack Overflow
このKBは合法ですか? はい、理由を学ぶ