Silverlight 5, службы ria с инфраструктурой сущности 6.0 alpha 3

entity-framework-6 silverlight-5.0 wcf-ria-services

Вопрос

Я пытаюсь создать приложение silverlight 5.0 с использованием служб ria с помощью entityframework 6.0 alpha 3. Это проект, который никогда не использовал какую-либо другую версию entityframework. Кажется, что все прекрасно компилируется, за исключением проекта данных Silverlight, который подключается к веб-проекту для создания прокси. Я получаю следующую ошибку:

Ошибка 2 Метод не найден: 'System.Data.Objects.ObjectContext System.Data.Entity.Infrastructure.IObjectContextAdapter.get_ObjectContext ()'

Есть ли несовместимость, или я просто делаю что-то неправильно?

Принятый ответ

RIA Services теперь является OpenSource с именем «Open RIA Services» (см. На CodePlex ).

Колин Блэр, руководитель проекта, только что анонсировал первую версию с поддержкой EF6: http://www.openriaservices.net/blog/post/The-Open-RIA-Services-Blog/1016/4-3-Alpha-NuGet -Packages-выход /

Вы можете установить пакет Nuget: службы RIA для платформы Entity Framework 6+ .

Если вы хотите установить пакет Nuget RIA Services для Entity Framework 6+ , обязательно выберите элемент «включить предварительную проверку» в верхнем комбинированном блоке.


Популярные ответы

Последней поддерживаемой версией для служб WCF RIA является Entity Framework 5 . Поэтому я не ожидал, что это сработает с EF 6.0.




Лицензировано согласно: CC-BY-SA with attribution
Не связан с Stack Overflow
Является ли этот КБ законным? Да, узнайте, почему
Лицензировано согласно: CC-BY-SA with attribution
Не связан с Stack Overflow
Является ли этот КБ законным? Да, узнайте, почему