Поддерживает ли Entity Framework 6 .NET 4.0?

.net-4.0 entity-framework-6

Вопрос

Я считаю, что Entity Framework 6 предназначен для .NET 4.5. Я хочу использовать его для проекта Visual Studio 2010, поэтому .NET 4.5 недоступен.

Поддерживает ли он .NET 4.0 и, следовательно, Visual Studio 2010?

Принятый ответ

Entity Framework 6 поддерживает .NET 4.0. Вы должны обновить свою версию NuGet, а затем повторите попытку. Вы можете скачать его на странице http://www.nuget.org/ . Я успешно загрузил EntityFramework 6.0.0-rc1 из основного канала nuget.org из приложения, ориентированного на .NET 4.0


Популярные ответы

История версий Entity Framework

EF6 Этот выпуск может использоваться в Visual Studio 2013, Visual Studio 2012 и Visual Studio 2010 (только для выполнения) для написания приложений, ориентированных на .NET 4.0 и .NET 4.5.



Лицензировано согласно: CC-BY-SA with attribution
Не связан с Stack Overflow
Является ли этот КБ законным? Да, узнайте, почему
Лицензировано согласно: CC-BY-SA with attribution
Не связан с Stack Overflow
Является ли этот КБ законным? Да, узнайте, почему