HotTowel EF6 MVC5 Угловая версия Breeze

asp.net-mvc-5 breeze entity-framework entity-framework-6 hottowel

Вопрос

Можно ли работать с HotTowel и EntityFramework 6 вместе?

Наш уровень DataAccess был обновлен до EF6. Единственной ссылкой, которую мы имеем для EntityFramework в веб-уровне, является Web.Config

 <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=5.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />

 <entityFramework>
   <defaultConnectionFactory type="System.Data.Entity.Infrastructure.SqlConnectionFactory, EntityFramework">
  <parameters>
      <parameter value="Data Source=.; Integrated Security=True; MultipleActiveResultSets=True" />
      </parameters>
   </defaultConnectionFactory>
</entityFramework>

Мы не можем обновить версию ER 6, потому что HotTowel Доступно обновление Breeze. Но как разрешить HotTowel

Ошибка установки. Откат ... install-package: обновление «Microsoft.AspNet.WebApi.OData 5.0.0» до «Microsoft.AspNet.WebApi.OData 4.0.30506» не выполнено. Не удалось найти версию «Breeze.Server.WebApi2», совместимую с «Microsoft.AspNet.WebApi.OData 4.0.30506».

EDIT: Мы используем KNOCKOUT.js библиотечную версию HotTowel.

Принятый ответ

Было несовместно, что Web APi v2 был, когда он вышел (на той же неделе, что и мой курс). Теперь он разрешен, поэтому просто установите

Install-Package HotTowel.Angular.Breeze -pre

Популярные ответы

QUICK версия John Papas отвечает ДА ​​Мне нужна предварительная версия HOtTowel, актуальная версия angularJS Pre. Но это не решило все проблемы. Мне нужны были бридж-пакеты для ef6, а также записи WEB.CONFIG.

Install-Package HotTowel.Angular.Breeze -pre

ТАКЖЕ мне пришлось использовать Install-Package Breeze.WebApi2.EF6

См. Их сайт для получения дополнительной информации. ПОЧЕМУ Breeze и EF6

Подробное объяснение того, что помогло запустить его. Примерно через 12 часов ... На всякий случай у кого-то есть проблема: я бы описал это как ef6, MVC5, Razor, Hottowel, AngularJs Breeze Knockout combo . КОМБИНАЦИЯ

<packages>
  <package id="AngularJS.Animate" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Core" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Route" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Sanitize" version="1.2.0-rc3" targetFramework="net45" />
  <package id="Antlr" version="3.5.0.2" targetFramework="net45" />
  <package id="Breeze.Client" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.ContextProvider" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.ContextProvider.EF6" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.WebApi2" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.WebApi2.EF6" version="1.4.5" targetFramework="net45" />
  <package id="Durandal" version="2.0.1" targetFramework="net45" />
  <package id="Durandal.Router" version="1.2.0" targetFramework="net45" />
  <package id="Durandal.Transitions" version="2.0.0" targetFramework="net45" />
  <package id="EntityFramework" version="6.0.1" targetFramework="net45" />
  <package id="FontAwesome" version="4.0.0" targetFramework="net45" />
  <package id="HotTowel.Angular" version="2.0.1-rc3" targetFramework="net45" />
  <package id="HotTowel.Angular.Breeze" version="2.0.1-rc3" targetFramework="net45" />
  <package id="infuser" version="0.2.1" targetFramework="net45" />
  <package id="jQuery" version="2.0.3" targetFramework="net45" />
  <package id="jQuery.Form" version="3.32" targetFramework="net45" />
  <package id="jQuery.UI.Combined" version="1.10.3" targetFramework="net45" />
  <package id="jQuery.Validation" version="1.11.1" targetFramework="net45" />
  <package id="Knockout.js_External_Template_Engine" version="2.0.5" targetFramework="net45" />
  <package id="Knockout.Mapping" version="2.4.0" targetFramework="net45" />
  <package id="Knockout.Validation" version="1.0.1" targetFramework="net45" />
  <package id="knockoutjs" version="2.3.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Mvc" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Mvc.FixedDisplayModes" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Razor" version="3.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Web.Optimization" version="1.1.2" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Client" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Core" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.OData" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Tracing" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.WebHost" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebPages" version="3.0.0" targetFramework="net45" />
  <package id="Microsoft.Data.Edm" version="5.6.0" targetFramework="net45" />
  <package id="Microsoft.Data.OData" version="5.6.0" targetFramework="net45" />
  <package id="Microsoft.Web.Infrastructure" version="1.0.0.0" targetFramework="net45" />
  <package id="Modernizr" version="2.6.2" targetFramework="net45" />
  <package id="Moment.js" version="2.1.0" targetFramework="net45" />
  <package id="Newtonsoft.Json" version="5.0.8" targetFramework="net45" />
  <package id="Q" version="0.9.7" targetFramework="net45" />
  <package id="RequireJS" version="2.1.8" targetFramework="net45" />
  <package id="RequireJS.Text" version="2.0.7" targetFramework="net45" />
  <package id="Sammy.js" version="0.7.4" targetFramework="net45" />
  <package id="Spin.js" version="1.3" targetFramework="net45" />
  <package id="System.Spatial" version="5.6.0" targetFramework="net45" />
  <package id="TinyMCE.JQuery" version="4.0.8" targetFramework="net45" />
  <package id="toastr" version="2.0.1" targetFramework="net45" />
  <package id="TrafficCop" version="0.3.1" targetFramework="net45" />
  <package id="Twitter.Bootstrap" version="2.3.2" targetFramework="net45" />
  <package id="Unity" version="3.0.1304.0" targetFramework="net45" />
  <package id="WebActivator" version="1.5.3" targetFramework="net45" />
  <package id="WebActivatorEx" version="2.0.2" targetFramework="net45" />
  <package id="WebGrease" version="1.5.2" targetFramework="net45" />
</packages>

И НЕКОТОРЫЕ ВЕРСИИ IMPORT WEB.CONFIG В разделе Views /

<packages>
  <package id="AngularJS.Animate" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Core" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Route" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Sanitize" version="1.2.0-rc3" targetFramework="net45" />
  <package id="Antlr" version="3.5.0.2" targetFramework="net45" />
  <package id="Breeze.Client" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.ContextProvider" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.ContextProvider.EF6" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.WebApi2" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.WebApi2.EF6" version="1.4.5" targetFramework="net45" />
  <package id="Durandal" version="2.0.1" targetFramework="net45" />
  <package id="Durandal.Router" version="1.2.0" targetFramework="net45" />
  <package id="Durandal.Transitions" version="2.0.0" targetFramework="net45" />
  <package id="EntityFramework" version="6.0.1" targetFramework="net45" />
  <package id="FontAwesome" version="4.0.0" targetFramework="net45" />
  <package id="HotTowel.Angular" version="2.0.1-rc3" targetFramework="net45" />
  <package id="HotTowel.Angular.Breeze" version="2.0.1-rc3" targetFramework="net45" />
  <package id="infuser" version="0.2.1" targetFramework="net45" />
  <package id="jQuery" version="2.0.3" targetFramework="net45" />
  <package id="jQuery.Form" version="3.32" targetFramework="net45" />
  <package id="jQuery.UI.Combined" version="1.10.3" targetFramework="net45" />
  <package id="jQuery.Validation" version="1.11.1" targetFramework="net45" />
  <package id="Knockout.js_External_Template_Engine" version="2.0.5" targetFramework="net45" />
  <package id="Knockout.Mapping" version="2.4.0" targetFramework="net45" />
  <package id="Knockout.Validation" version="1.0.1" targetFramework="net45" />
  <package id="knockoutjs" version="2.3.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Mvc" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Mvc.FixedDisplayModes" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Razor" version="3.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Web.Optimization" version="1.1.2" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Client" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Core" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.OData" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Tracing" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.WebHost" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebPages" version="3.0.0" targetFramework="net45" />
  <package id="Microsoft.Data.Edm" version="5.6.0" targetFramework="net45" />
  <package id="Microsoft.Data.OData" version="5.6.0" targetFramework="net45" />
  <package id="Microsoft.Web.Infrastructure" version="1.0.0.0" targetFramework="net45" />
  <package id="Modernizr" version="2.6.2" targetFramework="net45" />
  <package id="Moment.js" version="2.1.0" targetFramework="net45" />
  <package id="Newtonsoft.Json" version="5.0.8" targetFramework="net45" />
  <package id="Q" version="0.9.7" targetFramework="net45" />
  <package id="RequireJS" version="2.1.8" targetFramework="net45" />
  <package id="RequireJS.Text" version="2.0.7" targetFramework="net45" />
  <package id="Sammy.js" version="0.7.4" targetFramework="net45" />
  <package id="Spin.js" version="1.3" targetFramework="net45" />
  <package id="System.Spatial" version="5.6.0" targetFramework="net45" />
  <package id="TinyMCE.JQuery" version="4.0.8" targetFramework="net45" />
  <package id="toastr" version="2.0.1" targetFramework="net45" />
  <package id="TrafficCop" version="0.3.1" targetFramework="net45" />
  <package id="Twitter.Bootstrap" version="2.3.2" targetFramework="net45" />
  <package id="Unity" version="3.0.1304.0" targetFramework="net45" />
  <package id="WebActivator" version="1.5.3" targetFramework="net45" />
  <package id="WebActivatorEx" version="2.0.2" targetFramework="net45" />
  <package id="WebGrease" version="1.5.2" targetFramework="net45" />
</packages>

Затем в ROOT Web.Config проверьте, что эти записи в порядке версий

<packages>
  <package id="AngularJS.Animate" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Core" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Route" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Sanitize" version="1.2.0-rc3" targetFramework="net45" />
  <package id="Antlr" version="3.5.0.2" targetFramework="net45" />
  <package id="Breeze.Client" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.ContextProvider" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.ContextProvider.EF6" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.WebApi2" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.WebApi2.EF6" version="1.4.5" targetFramework="net45" />
  <package id="Durandal" version="2.0.1" targetFramework="net45" />
  <package id="Durandal.Router" version="1.2.0" targetFramework="net45" />
  <package id="Durandal.Transitions" version="2.0.0" targetFramework="net45" />
  <package id="EntityFramework" version="6.0.1" targetFramework="net45" />
  <package id="FontAwesome" version="4.0.0" targetFramework="net45" />
  <package id="HotTowel.Angular" version="2.0.1-rc3" targetFramework="net45" />
  <package id="HotTowel.Angular.Breeze" version="2.0.1-rc3" targetFramework="net45" />
  <package id="infuser" version="0.2.1" targetFramework="net45" />
  <package id="jQuery" version="2.0.3" targetFramework="net45" />
  <package id="jQuery.Form" version="3.32" targetFramework="net45" />
  <package id="jQuery.UI.Combined" version="1.10.3" targetFramework="net45" />
  <package id="jQuery.Validation" version="1.11.1" targetFramework="net45" />
  <package id="Knockout.js_External_Template_Engine" version="2.0.5" targetFramework="net45" />
  <package id="Knockout.Mapping" version="2.4.0" targetFramework="net45" />
  <package id="Knockout.Validation" version="1.0.1" targetFramework="net45" />
  <package id="knockoutjs" version="2.3.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Mvc" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Mvc.FixedDisplayModes" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Razor" version="3.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Web.Optimization" version="1.1.2" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Client" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Core" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.OData" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Tracing" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.WebHost" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebPages" version="3.0.0" targetFramework="net45" />
  <package id="Microsoft.Data.Edm" version="5.6.0" targetFramework="net45" />
  <package id="Microsoft.Data.OData" version="5.6.0" targetFramework="net45" />
  <package id="Microsoft.Web.Infrastructure" version="1.0.0.0" targetFramework="net45" />
  <package id="Modernizr" version="2.6.2" targetFramework="net45" />
  <package id="Moment.js" version="2.1.0" targetFramework="net45" />
  <package id="Newtonsoft.Json" version="5.0.8" targetFramework="net45" />
  <package id="Q" version="0.9.7" targetFramework="net45" />
  <package id="RequireJS" version="2.1.8" targetFramework="net45" />
  <package id="RequireJS.Text" version="2.0.7" targetFramework="net45" />
  <package id="Sammy.js" version="0.7.4" targetFramework="net45" />
  <package id="Spin.js" version="1.3" targetFramework="net45" />
  <package id="System.Spatial" version="5.6.0" targetFramework="net45" />
  <package id="TinyMCE.JQuery" version="4.0.8" targetFramework="net45" />
  <package id="toastr" version="2.0.1" targetFramework="net45" />
  <package id="TrafficCop" version="0.3.1" targetFramework="net45" />
  <package id="Twitter.Bootstrap" version="2.3.2" targetFramework="net45" />
  <package id="Unity" version="3.0.1304.0" targetFramework="net45" />
  <package id="WebActivator" version="1.5.3" targetFramework="net45" />
  <package id="WebActivatorEx" version="2.0.2" targetFramework="net45" />
  <package id="WebGrease" version="1.5.2" targetFramework="net45" />
</packages>

никаких изменений не требуется. Пространства имен, но на всякий случай.

<packages>
  <package id="AngularJS.Animate" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Core" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Route" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Sanitize" version="1.2.0-rc3" targetFramework="net45" />
  <package id="Antlr" version="3.5.0.2" targetFramework="net45" />
  <package id="Breeze.Client" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.ContextProvider" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.ContextProvider.EF6" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.WebApi2" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.WebApi2.EF6" version="1.4.5" targetFramework="net45" />
  <package id="Durandal" version="2.0.1" targetFramework="net45" />
  <package id="Durandal.Router" version="1.2.0" targetFramework="net45" />
  <package id="Durandal.Transitions" version="2.0.0" targetFramework="net45" />
  <package id="EntityFramework" version="6.0.1" targetFramework="net45" />
  <package id="FontAwesome" version="4.0.0" targetFramework="net45" />
  <package id="HotTowel.Angular" version="2.0.1-rc3" targetFramework="net45" />
  <package id="HotTowel.Angular.Breeze" version="2.0.1-rc3" targetFramework="net45" />
  <package id="infuser" version="0.2.1" targetFramework="net45" />
  <package id="jQuery" version="2.0.3" targetFramework="net45" />
  <package id="jQuery.Form" version="3.32" targetFramework="net45" />
  <package id="jQuery.UI.Combined" version="1.10.3" targetFramework="net45" />
  <package id="jQuery.Validation" version="1.11.1" targetFramework="net45" />
  <package id="Knockout.js_External_Template_Engine" version="2.0.5" targetFramework="net45" />
  <package id="Knockout.Mapping" version="2.4.0" targetFramework="net45" />
  <package id="Knockout.Validation" version="1.0.1" targetFramework="net45" />
  <package id="knockoutjs" version="2.3.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Mvc" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Mvc.FixedDisplayModes" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Razor" version="3.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Web.Optimization" version="1.1.2" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Client" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Core" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.OData" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Tracing" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.WebHost" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebPages" version="3.0.0" targetFramework="net45" />
  <package id="Microsoft.Data.Edm" version="5.6.0" targetFramework="net45" />
  <package id="Microsoft.Data.OData" version="5.6.0" targetFramework="net45" />
  <package id="Microsoft.Web.Infrastructure" version="1.0.0.0" targetFramework="net45" />
  <package id="Modernizr" version="2.6.2" targetFramework="net45" />
  <package id="Moment.js" version="2.1.0" targetFramework="net45" />
  <package id="Newtonsoft.Json" version="5.0.8" targetFramework="net45" />
  <package id="Q" version="0.9.7" targetFramework="net45" />
  <package id="RequireJS" version="2.1.8" targetFramework="net45" />
  <package id="RequireJS.Text" version="2.0.7" targetFramework="net45" />
  <package id="Sammy.js" version="0.7.4" targetFramework="net45" />
  <package id="Spin.js" version="1.3" targetFramework="net45" />
  <package id="System.Spatial" version="5.6.0" targetFramework="net45" />
  <package id="TinyMCE.JQuery" version="4.0.8" targetFramework="net45" />
  <package id="toastr" version="2.0.1" targetFramework="net45" />
  <package id="TrafficCop" version="0.3.1" targetFramework="net45" />
  <package id="Twitter.Bootstrap" version="2.3.2" targetFramework="net45" />
  <package id="Unity" version="3.0.1304.0" targetFramework="net45" />
  <package id="WebActivator" version="1.5.3" targetFramework="net45" />
  <package id="WebActivatorEx" version="2.0.2" targetFramework="net45" />
  <package id="WebGrease" version="1.5.2" targetFramework="net45" />
</packages>

и некоторые зависящие настройки сборки к версиям

<packages>
  <package id="AngularJS.Animate" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Core" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Route" version="1.2.0-rc3" targetFramework="net45" />
  <package id="AngularJS.Sanitize" version="1.2.0-rc3" targetFramework="net45" />
  <package id="Antlr" version="3.5.0.2" targetFramework="net45" />
  <package id="Breeze.Client" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.ContextProvider" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.ContextProvider.EF6" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.Server.WebApi2" version="1.4.5" targetFramework="net45" />
  <package id="Breeze.WebApi2.EF6" version="1.4.5" targetFramework="net45" />
  <package id="Durandal" version="2.0.1" targetFramework="net45" />
  <package id="Durandal.Router" version="1.2.0" targetFramework="net45" />
  <package id="Durandal.Transitions" version="2.0.0" targetFramework="net45" />
  <package id="EntityFramework" version="6.0.1" targetFramework="net45" />
  <package id="FontAwesome" version="4.0.0" targetFramework="net45" />
  <package id="HotTowel.Angular" version="2.0.1-rc3" targetFramework="net45" />
  <package id="HotTowel.Angular.Breeze" version="2.0.1-rc3" targetFramework="net45" />
  <package id="infuser" version="0.2.1" targetFramework="net45" />
  <package id="jQuery" version="2.0.3" targetFramework="net45" />
  <package id="jQuery.Form" version="3.32" targetFramework="net45" />
  <package id="jQuery.UI.Combined" version="1.10.3" targetFramework="net45" />
  <package id="jQuery.Validation" version="1.11.1" targetFramework="net45" />
  <package id="Knockout.js_External_Template_Engine" version="2.0.5" targetFramework="net45" />
  <package id="Knockout.Mapping" version="2.4.0" targetFramework="net45" />
  <package id="Knockout.Validation" version="1.0.1" targetFramework="net45" />
  <package id="knockoutjs" version="2.3.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Mvc" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Mvc.FixedDisplayModes" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Razor" version="3.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.Web.Optimization" version="1.1.2" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Client" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Core" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.OData" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.Tracing" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebApi.WebHost" version="5.0.0" targetFramework="net45" />
  <package id="Microsoft.AspNet.WebPages" version="3.0.0" targetFramework="net45" />
  <package id="Microsoft.Data.Edm" version="5.6.0" targetFramework="net45" />
  <package id="Microsoft.Data.OData" version="5.6.0" targetFramework="net45" />
  <package id="Microsoft.Web.Infrastructure" version="1.0.0.0" targetFramework="net45" />
  <package id="Modernizr" version="2.6.2" targetFramework="net45" />
  <package id="Moment.js" version="2.1.0" targetFramework="net45" />
  <package id="Newtonsoft.Json" version="5.0.8" targetFramework="net45" />
  <package id="Q" version="0.9.7" targetFramework="net45" />
  <package id="RequireJS" version="2.1.8" targetFramework="net45" />
  <package id="RequireJS.Text" version="2.0.7" targetFramework="net45" />
  <package id="Sammy.js" version="0.7.4" targetFramework="net45" />
  <package id="Spin.js" version="1.3" targetFramework="net45" />
  <package id="System.Spatial" version="5.6.0" targetFramework="net45" />
  <package id="TinyMCE.JQuery" version="4.0.8" targetFramework="net45" />
  <package id="toastr" version="2.0.1" targetFramework="net45" />
  <package id="TrafficCop" version="0.3.1" targetFramework="net45" />
  <package id="Twitter.Bootstrap" version="2.3.2" targetFramework="net45" />
  <package id="Unity" version="3.0.1304.0" targetFramework="net45" />
  <package id="WebActivator" version="1.5.3" targetFramework="net45" />
  <package id="WebActivatorEx" version="2.0.2" targetFramework="net45" />
  <package id="WebGrease" version="1.5.2" targetFramework="net45" />
</packages>



Лицензировано согласно: CC-BY-SA with attribution
Не связан с Stack Overflow
Является ли этот КБ законным? Да, узнайте, почему
Лицензировано согласно: CC-BY-SA with attribution
Не связан с Stack Overflow
Является ли этот КБ законным? Да, узнайте, почему