Не удалось найти запрашиваемый поставщик данных .Net Framework. Он не может быть установлен

ef-code-first ef-migrations entity-framework entity-framework-6

Вопрос

Сегодня утром я неожиданно получил это исключение, пытаясь добавить настраиваемый шаг перехода к нашим EF Code-first migrations:

Поставщик ADO.NET с инвариантным именем «поставщик данных .NET Framework для SQL Server» либо не зарегистрирован в конфигурационном файле машины или приложения, либо не может быть загружен.

У меня нет проблем с выполнением базы данных обновлений на нашем SQL Server, но команда add-migration терпит неудачу.

Мы используем.Net 4.5.1 с EF Code First 6.0.1 против SQL Server 2012.

Наш файл конфигурации для нашего проекта данных:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <configSections>
    <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
  </configSections>
  <entityFramework>
    <defaultConnectionFactory type="System.Data.Entity.Infrastructure.SqlConnectionFactory, EntityFramework">
      <parameters>
        <parameter value="System.Data.SqlClient" />
      </parameters>
    </defaultConnectionFactory>
    <providers>
      <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
    </providers>
  </entityFramework>
  <connectionStrings>
    <add name="Data.StorageContext" connectionString="server=.\MSSQL01;Database=OutageTracking; Integrated Security=True; MultipleActiveResultSets=True" providerName="System.Data.SqlClient" />
  </connectionStrings>
  <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5.1" />
  </startup>
</configuration>

Обратите внимание, что Visual Studio 2012 жалуется на -element в разделе.

Есть предположения?

Благодаря,

/ Jesper

Принятый ответ

«Поставщик данных .NET Framework для SQL Server» не является инвариантным именем, поэтому какой-то файл .config должен находиться в плохом состоянии



Лицензировано согласно: CC-BY-SA with attribution
Не связан с Stack Overflow
Является ли этот КБ законным? Да, узнайте, почему
Лицензировано согласно: CC-BY-SA with attribution
Не связан с Stack Overflow
Является ли этот КБ законным? Да, узнайте, почему