EntityFramework 6 Alpha 2和MySQL Connector / NET 6.6.4

entity-framework entity-framework-6 mysql mysql-connector

6.6.4 MySQL .NET連接器顯然支持EF6。我已經從EF5和.NET 4升級到EF6 alpha2和.NET 4.5。自升級以來,我重新創建了ADO.NET實體數據模型。

在對數據庫做任何事情后,它會拋出一條異常消息說;

ItemModel.ssdl(2,2):錯誤0152:找不到'MySql.Data.MySqlClient'ADO.NET提供程序的實體框架提供程序。確保提供程序已在應用程序配置文件的“entityFramework”部分中註冊。有關詳細信息,請參閱http://go.microsoft.com/fwlink/?LinkId=260882

目前我的app.config文件包含;

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <configSections>
    <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
    <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
  </configSections>
  <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5" />
  </startup>
<entityFramework>
    <defaultConnectionFactory type="System.Data.Entity.Infrastructure.SqlConnectionFactory, EntityFramework" />
</entityFramework>
<connectionStrings>
    <add name="ItemEntities" connectionString="metadata=res://*/ItemModel.csdl|res://*/ItemModel.ssdl|res://*/ItemModel.msl;provider=MySql.Data.MySqlClient;provider connection string=&quot;server=localhost;user id=user;password=password;persist security info=True;database=Item_dbo&quot;" providerName="System.Data.EntityClient" />
  </connectionStrings>
</configuration>

我的app.config中是否存在合法缺失的配置項,或者我只是使用了MySQL連接器和EF alpha的版本,這些版本之間根本不兼容?

我的目的是讓它在單聲道3.0.3下運行,這在Windows上證明是成功的。

熱門答案

簡單地將此添加到您的web.config

  <system.data>
    <DbProviderFactories>
      <remove invariant="MySql.Data.MySqlClient" />
      <add name="MySQL Data Provider" invariant="MySql.Data.MySqlClient" description=".Net Framework Data Provider for MySQL" type="MySql.Data.MySqlClient.MySqlClientFactory, MySql.Data, Version=6.6.4.0" />
    </DbProviderFactories>
  </system.data>

  <entityFramework>
    <providers>
      <provider invariantName="MySql.Data.MySqlClient" type="MySql.Data.MySqlClient.MySqlClientFactory, MySql.Data, Version=6.6.4.0" >
      </provider>
    </providers>
  </entityFramework>

但我不認為你可以使用6.6.4與EF6 ...




許可下: CC-BY-SA with attribution
不隸屬於 Stack Overflow
這個KB合法嗎? 是的,了解原因
許可下: CC-BY-SA with attribution
不隸屬於 Stack Overflow
這個KB合法嗎? 是的,了解原因