ODAC 12c和實體框架6

c# entity-framework entity-framework-6 odac oracle

誰能告訴我Oracle數據訪問組件12c是否與Entity Framework 6兼容? Oracle網站是文檔的噩夢,無法找到有關如何解決此問題的任何參考。

我有一個現有項目,我正在嘗試升級到ODAC 12c和EF6,但我收到以下錯誤,我正在努力解決:

例外

我創建了一個新項目來排除現有項目的任何問題,我也遇到了同樣的問題。我認為這是由Entity Framework Power Tools Beta 4 (逆向工程師代碼優先)自動編輯的app.config文件的問題:

配置文件

誰能指出我正確的方向?

一般承認的答案

** Oracle數據訪問組件12c版本3 Beta 2 ** ODAC 12c R3是第一個使用Entity Framework(EF)6和EF Code First認證的ODP.NET版本。 http://www.oracle.com/technetwork/topics/dotnet/whatsnew/index.html


熱門答案

Devart最近宣布了Oracle 12c支持 。您可能需要考慮使用其提供程序。




許可下: CC-BY-SA with attribution
不隸屬於 Stack Overflow
這個KB合法嗎? 是的,了解原因
許可下: CC-BY-SA with attribution
不隸屬於 Stack Overflow
這個KB合法嗎? 是的,了解原因