Entity Framework 5.0 - minimum .Net Framework version required ? .Net 4.0 or 4.5?

.net entity-framework

Question

For Entity Framework 5.0, What is the minimum .Net Framework version required ? either .Net 4.0 or 4.5 ?

1
10
8/28/2012 9:51:40 PM

Accepted Answer

That depends on what you mean by "required".

In order to use all features, .NET 4.5 is required. However, EF5 will run on .NET 4, but will basically function the same as EF 4.3.

EDIT:

EF5 will still provide some minor performance enhancements on .NET 4, and will of course provide bug fixes, but will not provide the majority of new features (like Enum support, Spatial types, etc..)

EDIT (6/24/12):

As of EF6, the new performance features were moved out of the core framework, so you can now get full benefits on .NET 4, but EF5 is still dependent upon 4.5 for the improvements.

18
6/24/2014 2:57:28 PM


Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow