Silverlight 5, ria services with entity framework 6.0 alpha 3

entity-framework-6 silverlight-5.0 wcf-ria-services

Question

I am trying to create a silverlight 5.0 application using ria services, with entityframework 6.0 alpha 3. This is a greenfield project that never used any other version of entityframework. Everything seems to compile fine, except for the silverlight data project that connects to the web project to generate proxies. I get the following error:

Error 2 Method not found: 'System.Data.Objects.ObjectContext System.Data.Entity.Infrastructure.IObjectContextAdapter.get_ObjectContext()'

Is there an incompatibility or am I just doing something wrong?

1
3
5/14/2013 1:03:03 PM

Accepted Answer

RIA Services is now OpenSource with the name "Open RIA Services" (see on CodePlex).

Colin Blair, the project leader, has just announced the first version with EF6 support : http://www.openriaservices.net/blog/post/The-Open-RIA-Services-Blog/1016/4-3-Alpha-NuGet-Packages-Released/

You can install the Nuget package : RIA Services for Entity Framework 6+.

If you want to install the Nuget package RIA Services for Entity Framework 6+, be sure to select the "include prerelease" item in the top combo Box.

1
2/8/2014 7:52:40 PM

Popular Answer

The latest supported version for WCF RIA Services is Entity Framework 5. So i would not expect that this will work with EF 6.0.



Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow