IdentityStoreManager could not be found after upgrading Microsoft.AspNet.Identity to rc1

asp.net-identity asp.net-mvc-5 entity-framework-6 visual-studio-2013

Question

Multiple problems in the AccountController.cs and AppModel.cs classes, which are produced by the default MVC5 templates in Visual Studio 2013, start to appear after upgrading Microsoft.AspNet.Identity.Core to 1.0.0-rc1.

Are there any release notes available that detail how to fix the problematic changes?

1
11
8/24/2013 11:28:30 AM

Accepted Answer

The following nuget packages need be updated:

  • Version="1.0.0-rc1" of the Microsoft ASP.NET Identity EntityFramework
  • Version 2.0.0-rc1 of Microsoft.Owin.Security is used.
  • Version 2.0.0-rc1 of Microsoft.Owin.Security.OAuth is used.

Take these:

  • The version of Microsoft.AspNet.Identity.Owin is "1.0.0-rc1".
  • Version 2.0.0-rc1 of Microsoft.Owin.Host.SystemWeb is used.

The AccountController.cs file will then still have a significant number of problems. The classes are now in your project, so you can correct them, or you can use my AccountController.cs file, which is fixed. It builds and the program runs, but there is a location (noted with a to-do:) that I'm not sure about yet.

My AccountController.cs code is available for download from my sample project on github here: https://github.com/onybo/Asp.Net-Identity-RC1-sample-app

13
8/24/2013 9:51:31 PM


Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow