Does Entity Framework 6 support .NET 4.0?

.net-4.0 entity-framework-6

Question

I believe Entity Framework 6 is intended for .NET 4.5. I'm wanting to use it for a Visual Studio 2010 project, so .NET 4.5 isn't available.

Does it support .NET 4.0 and hence Visual Studio 2010?

Accepted Answer

Entity Framework 6 does support .NET 4.0. You should update your version of NuGet then try again. You can find the download at http://www.nuget.org/. I successfully downloaded EntityFramework 6.0.0-rc1 from the main nuget.org feed from an application targeting .NET 4.0


Popular Answer

Entity Framework Version History

EF6 This release can be used in Visual Studio 2013, Visual Studio 2012 and Visual Studio 2010 (runtime only) to write applications that target .NET 4.0 and .NET 4.5.




Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Is this KB legal? Yes, learn why
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Is this KB legal? Yes, learn why