ADO.NET provider with invariant name 'System.Data.SqlServerCe.4.0' could not be loaded

.net breeze entity-framework sql-server-ce-4 visual-studio-2013

Question

The Entity Framework provider type 'System.Data.Entity.SqlServerCompact.SqlCeProviderServices, EntityFramework.SqlServerCompact' registered in the application config file for the ADO.NET provider with invariant name 'System.Data.SqlServerCe.4.0' could not be loaded. Make sure that the assembly-qualified name is used and that the assembly is available to the running application.

Above is the error message I am getting when trying to create metadata with Breeze / Entity Framework. Nuget seems to have messed something up but it is not obvious what and it is not obvious where it is trying to read the assembly from. Any ideas would be most welcome.

1
6
6/27/2014 6:18:52 PM

Popular Answer

I had the same problem. You have installed Sql Compact but you are missing the EntityFramework extension for Sql Compact. You need to install it via package manager console or nuget package manager. The console script is :

Install-Package EntityFramework.SqlServerCompact 
12
12/15/2015 2:37:48 PM


Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow