EntityFramework 6.1.3 does not support framework .NETPlatform,Version=v5.4 on visual studio 2015

entity-framework-6 json

Question

Any idea why I receive the following error after Nuget installing Entity framework 6.1.3?

Error notice: "The dependency EntityFramework 6.1.3 in project foo bar does not support framework .NETPlatform,Version=v5.4"

Here's my global.json (edited out personal data)

{
  "version": "1.0.0-*",
  "description": foo bar Class Library",
  "authors": [ "foo bar" ],
  "tags": [ "" ],
  "projectUrl": "",
  "licenseUrl": "",
  "frameworks": {
    "net451": { },
    "dotnet5.4": {
      "dependencies": {
        "Microsoft.CSharp": "4.0.1-beta-23516",
        "System.Collections": "4.0.11-beta-23516",
        "System.Linq": "4.0.1-beta-23516",
        "System.Runtime": "4.0.21-beta-23516",
        "System.Threading": "4.0.11-beta-23516"
      }
    }
  },
  "dependencies": {
    "EntityFramework": "6.1.3"
  }
}
1
15
12/28/2015 4:34:50 AM

Popular Answer

I solved by deleting this line - "net451": { },, and then replacing "dotnet5.4" with "net451".

9
12/28/2015 4:17:41 AM


Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow