Unable to install PostgreSQL entity framework nuget package for .Net 4.5?

.net asp.net-mvc entity-framework-6 npgsql visual-studio-2013

Question

I am getting :

Could not install package 'Npgsql.EntityFrameworkCore.PostgreSQL 2.0.1'. You are trying to install this package into a project that targets 
'.NETFramework,Version=v4.5.1', but the package does not contain any assembly 
references or content files that are compatible with that framework.

What am I missing?

enter image description here

1
0
1/29/2018 7:30:28 AM

Accepted Answer

If you're looking for Entity Framework Core, then version 2.0.x is only supported for .NET Standard 2.0, which is supported by .NET Framework 4.6.1 and above (or .NET Core).

If you're looking for Entity Framework 6.x, use the package EntityFramework6.Npgsql as suggested above.

1
1/29/2018 7:58:33 AM


Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow