Referencing .net 4.7 framework assemblies in .net core 2 solution

.net asp.net-core-2.0 c# entity-framework-6

Question

When I attempt to reference a.net 4.7 DLL in my Asp.NetCore 2 MVC project, I get a problem. The mistake is reproduced beneath:

PM> Install-Package Microsoft.NETCore.App -Version 2.0.0 Restoring packages for ../Web.csproj... Install-Package : Package Microsoft.NETCore.App 2.0.0 is not compatible with net47 (.NETFramework,Version=v4.7). Package Microsoft.NETCore.App 2.0.0

supports:

  • netcoreapp (.NETCoreApp,Version=v0.0)
  • netcoreapp2.0 (.NETCoreApp,Version=v2.0)

The web programme will utilise the entity framework 6 library from the.Net 4.7 assembly (core2 mvc). My core 2 web application has been upgraded to target many frameworks (netcoreapp2.0;net4.7).

Therefore, I suppose the question I'm attempting to pose is how I may utilise a.Net4.7 assembly in an ASP.Net core2.0 application.

1
5
2/6/2018 1:00:35 PM

Accepted Answer

ZZZ_tmp
3
2/7/2018 9:22:44 AM


Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow