BreezeJS和Entity Framework 6.0.1

breeze entity-framework entity-framework-6

我正在嘗試創建一個Breeze Web API控制器,我想知道是否可以使用Visual Studio 2013附帶的默認MVC / Web API項目模板。通過Nuget數據包管理器更新所有內容安裝Entity Framework 6.0.1。嘗試在此之後安裝Breeze會導致錯誤,因為它嘗試將EF 5作為依賴項安裝,這是不可能的,因為模板的其他部分依賴於EF6。我們是否必須等待適用於EF6的新版Breeze?

編輯:我想使用[BreezeController]和Odata這樣做“微風”。

一般承認的答案

更新於2013年10月29日

截至目前,Breeze 1.4.5支持Microsoft的ASP.NET WebApi 2和Entity Framework 6.請參閱http://www.breezejs.com/documentation/download

老帖子:

我們還沒有支持EF6,但很快就會......


熱門答案

我只是想補充一點,即使沒有EF6.1,今天發布的VS2013的MVC 5更新也是輕而易舉的。很難將各個部分分開來確定哪個新部件負責。它可能是MVC或新的odata。無論如何,我們焦急地期待新版本。



許可下: CC-BY-SA with attribution
不隸屬於 Stack Overflow
這個KB合法嗎? 是的,了解原因
許可下: CC-BY-SA with attribution
不隸屬於 Stack Overflow
這個KB合法嗎? 是的,了解原因